Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.

Strange crawl/sitemap errors, many pages not found

0 votes
631 views
asked May 2, 2012 in Plugins by Dude

Not sure what happens. In my Google Webmaster Tools I have over 50 Crawl Errors. 

Any changes in xml-sitemap plugin. Google found links like a (error of course):

questions/register?to=

or

questions/literatura/czym-jest-quask-pl

where 'literatura' is category and 'czym-jest-qask-pl' is custom page (not plugin, just standard page created in admin).

I have other Q&A sites, and no problem like this. Any idea what happens?

Q2A version: 1.5.1
commented May 3, 2012 by Dude
Looks like a fixed now. I selected all errors as 'fixed' in webmaster tools. But also, I had link on all pages in "welcome module" this yellow one. It was <a href="czym-jest-qask-pl">czym jest qask.pl</a>
Now link is <a href="../czym-jest-qask-pl">czym jest qask.pl</a> maybe it maked error, but should not.
commented May 3, 2012 by Dude
More. I think, this is bug. I found again broken link.
This is category page (empty now):http://qask.pl/questions/prawo-i-finanse/prawo
and here q&a generating link: http://qask.pl/questions/czym-jest-qask-pl
where should be http://qask.pl/czym-jest-qask-pl of course.
link source is <a href="../czym-jest-qask-pl">czym-jest-qask-pl</a>, and should be ok, but is not. I will change it now to <a href="http://qask.pl/czym-jest-qask-pl">czym-jest-qask-pl</a>

Please log in or register to answer this question.

...