Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.

Has anyone tried the beta of version 1.2?

+8 votes
asked Jun 27, 2010 in Q2A Core by gidgreen
The download is here:


Please let me know how it worked for you - good or otherwise!

7 Answers

0 votes
answered Jun 27, 2010 by SportTipsWorld
Think its awesome !

Would prefer to use our own menu. But beggers cannot be choosers.

Beta version here:

commented Jun 27, 2010 by minnkyaw
edited Jun 27, 2010 by minnkyaw
Yes, I tried but it is better than before. BTW RSS feed is going to wrong place or how can change to sidebar?
commented Jun 27, 2010 by gidgreen
You need to copy the qa-styles.css file from the Default theme that comes with version 1.2 to your custom theme.
commented Jun 27, 2010 by minnkyaw
Yes, it is work now. Thank you.
+1 vote
answered Jun 28, 2010 by ProThoughts

I'm testing 1.2 beta version with test database and it is working fantastic! no issues for upgrading from old database. I'll be upgrading site as soon as new theme is ready.

I see lots of features in this new release, beyond my expectations, excellent work! kudos to you!

If Q2A moves at this speed I'm sure it will be most popular QA solution very soon.
0 votes
answered Jun 28, 2010 by R
Hi Gidgreen,
Im doing testing in local...
Im exploring all options in admin page...
Im so happy.. you are rocking...
hats off to your team....

Will upload in production soon... but may take time to explore all options :D

Thank you very much!
0 votes
answered Jun 30, 2010 by ProThoughts
Q2A 1.2 beta1 is active on http://answers.prothoughts.com

no issues for database upgrade or installation. thanks for this wonderful release.
0 votes
answered Jun 30, 2010 by R
Great... Now we are in new version... Simple to upgrade.. took time to do some changes in custom theme...


Thanks to Gidgreen & team! Great work... :)
commented Jun 30, 2010 by monk333
Hello R,

would You consider to provide Your theme to the community ? I am asking so, as the theme is really well elaborated !

Thank You
commented Jun 30, 2010 by R
Credit goes to Dakoda (http://www.question2answer.org/qa/user/Dakota)
His original theme can be seen here: http://www.question2answer.org/qa/1382/do-we-have-any-beautiful-themes-for-q2a

I have modified bit to make it work for new beta1.2 version..
Im happy to share the same..
0 votes
answered Jun 30, 2010 by monk333
Very well done.

In comparison to the themeforrest and temlplatic wp answer themes this new version provides most important qa site features. It lacks a little bit at community building, through missing user pics, facebook login and more options regarding the user site.
Good is, that You dont need the wp overhead.

The advantage regarding other ask an expert similar solutions, is, that it is written in php and not python, which makes problems with some hosting providers.

With some more admin control over the questions and answers and eventually an easier to understand templating system like smarty, this script soon will be best on the market.

Crucial is to attract the themeexperts. once there are many themes available, more users will use it.

I as well tried joomla and drupal to build a good Q&A site, but joomla I dont really like and drupal needs to many modules to make it interesting. For Drupal as well it is not very easy to build new themes.

Actually I am changing some things on the 1.2 version, after that I will use it on my production sites.

Thank You for this excellent work!!!
0 votes
answered Jun 30, 2010 by sama55
I'm translating and testing it from aspect of L10N. Because there were many changes, I started it early. The translator had better be careful (^start^aaaaaa^close) of qa-lang-emails.php. I want to submit  translation archive around RC phase(When will it be?).

And, I do not yet look in detail, RSS preview from admin panel strange...
my test browser is Chrome/FireFox, and question data are 0 or 1.
commented Jul 1, 2010 by gidgreen
Can you send me a screenshot or a link where I can see this problem?
commented Jul 1, 2010 by sama55
FireFox is OK. But Google Chrome display error. A cause is that XML declaration disappears. It seems to be bug of Chrome. Sorry that I disturb.
Error Message of Chrome:
This page contains the following errors:
error on line 1 at column 1: Document is empty
Below is a rendering of the page up to the first error.