Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.

closed Users Are Not Receiving Confirmation Email - Need Detailed Answer

+1 vote
1,247 views
asked Aug 12, 2012 in Q2A Core by notpanda
closed Aug 14, 2012 by notpanda

Hello Q2A Community!

First I appreciate developers' and contributors' effort in making this cool piece of software. It's a very nice experience of downloading, installing and designing my very own Q2A site. However, when I finished designing my site, I created (a dummy) user account (besides admin account) and waited for the confirmation email on my @live.com email address - as I've setup the settings so that only "registred with confirmed email" can post questions and answers. But unfortunately I didn't receive any email. So, my question is very simple.

Q. How can I fix this issue?

Here is what I'm using:

  • Linux hosting
  • cPanel

Here is what I've done so far:

  • Downloaded the Q2A software.
  • Uploaded the Q2A software to a folder being pointed by the subdomain.
  • Installed Q2A software
  • Designed the Q2A website
  • Setup a dummy user account to check whether the software is properly functioning or not.
  • (Didn't received any email in the account!)
  • Googled and searched question2answer.org/qa website but didn't find any working fix.
  • Created an email account with no-reply@subdomain.domain.com in cPanel because this is the default email address for sending confirmation emails in the admin panel. (Seems stupid? I'm sorry about this. I don't have much knowledge of networking and mailing servers)

Another question:

Q. As I'm using Linux hosting with cPanel so do I need to add some script / code which can link the website with the cPanel mail server so that emails can be sent?

Thank you very much for you time

Thanks,

Update August 14, 2012

Everything seems to working fine automatically. I created two to three dummy accounts and found that now I can receive the confirmation emails.

Q2A version: 1.5.2
closed with the note: Problem solved automatically.
commented Jul 17, 2014 by Dipanshu
Which hosting you are using?
...