Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.

Though i am getting my site in search but i am not geeting search results if searched by my sites content. helppp !!!

0 votes
438 views
asked Aug 27, 2014 in Q2A Core by Sam and Rodriguez
This is a big issue help. If i search by my site name then i get many results in search engine, but if i search by the contents or questions of my site then i dnt get my site links. This is a serious issue . plz help. whats the use of putting my site in search results if i dnt get my sites name when searched by its content??
commented Aug 27, 2014 by maxjtechno
you should post an example to better  explain the issue you are facing
commented Aug 28, 2014 by Sam and Rodriguez
see my site is movietown.tk , if i serach in google by "movietown.tk" then i get my site in search results. But suppose there is a question in my site " when will thiss happen??" . then when i search in google by this question i dnt get any results in any page . so thats what i am asking is how do i get my sites links in search result if searched by its content.?????

1 Answer

+3 votes
answered Aug 28, 2014 by maxjtechno

Let's see if I've understood... If I consider for instance the question with title : "Here It Is . Happy New Year Official Trailer !!", I can see that google has not indexed its content (for instance, the text of an answer  : "Awesomeee. Super. All records will be broken . 300 crores nett sureshot. Charlie gonna rock") :

https://www.google.com/#q=%22Awesomeee.+Super.+All+records+will+be+broken+.+300+crores+nett+sureshot.+Charlie+gonna+rock%22+site%3Amovietown.tk

Correct ?

I think that the issue is the design of your website : it uses frames.

You can also notice that the url in your browser does not change when you navigate through the pages.

Your main site is movietown.tk , but the real pages (where the content of the questions is) have another URL (are on another domain) : moviehome.byethost15.com

In the prevoius example, the real URL of the question is :

http://moviehome.byethost15.com/167/here-it-is-happy-new-year-official-trailer

You can see that it's not indexed neither using "movieton.tk" :

https://www.google.com/#q=site:http:%2F%2Fmovietown.tk%2F167%2Fhere-it-is-happy-new-year-official-trailer

nor using "moviehome.byethost15.com" :

https://www.google.com/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=site:http:%2F%2Fmoviehome.byethost15.com%2F167%2Fhere-it-is-happy-new-year-official-trailer

As google says : "Google tries to associate framed content with the page containing the frames, but we don't guarantee that we will"

It also say that there could be some workarouds  (for instance using the NOFRAME metatag).

Personally I would avoid the use of frames.

 

commented Aug 30, 2014 by Sam and Rodriguez
so how to get rid of these frame thing ?? so that my questions and answers are indexed by google too??
commented Aug 31, 2014 by maxjtechno
As I wrote before, you should *first* understand why the frames are there :
1) is it related to a frame forwarding approach ?
2) have you modified your q2a code ?
*After* you have understood that, in case of 2) I think you better avod the use of frames ----> modify your code again (or, but I don't like this approach, use some workarounds as in the link I've posted before)
In case of 1) : are you in a situation where you have a domain registrar (freenom ?) separate from your hosting provider (byethost ?) ? Verify with your domain registrar if you are mapping your domain name to your server with "frame forwarding". In this case you should change approach; it would be better that your domain registrar allows you to use an external DNS, so that you can update your current nameservers to point to the nameservers of your hosting provider (ask your hosting providers the details of them).
...