Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.

Q2A 1.8 beta2 released

+13 votes
344 views
asked Dec 23, 2017 in Q2A Core by Scott

Hello everyone, here's a little last minute Christmas present! :D I've released a second beta for version 1.8 of Q2A. There are quite a few fixes so I thought it made sense to do another beta. If all goes well then the final release will come very soon in January.

The beta release is here

This includes the correct zip file, same as will be on the website when Gideon updates it (not expecting it soon of course, given it's the holiday season). In the future I'll be taking a little more control over the Q2A website and be able to fully release stuff myself in future.

Changelog:

  • Fixed errors with output buffering and gzip compression.
  • Fixed non-ANSI group-by queries in MySQL 5.7.
  • Fixed notices on PHP 7.2.
  • Fixed points recalculation when converting answers to comments.
  • Added generic `.qa-post-content` class to replace old `.entry-content` which was removed.
  • Fixed non-unique cache keys.
  • Reworked file cache to securely allow cache inside web root.
  • Fixed issue with PHPMailer's autoloader on PHP 7.2.
  • Removed (non-functional) clipboard from CKEditor.

And lastly, Merry Christmas and happy holidays to everyone in the Q2A community! Here's to a productive 2018.

commented Dec 23, 2017 by Gurjyot Singh
Merry Christmas @Scott :)
commented Dec 23, 2017 by Shrisun
Merry Christmas
commented Dec 24, 2017 by poVoq
Could you quickly describe what the easiest way to update is? Just backup the old qa-config file and replace the rest?
commented Dec 24, 2017 by Scott
@poVoq back up the database first in case anything goes wrong. Then replace all the files like you said. Then visit your site and you should get an update prompt.
commented Dec 24, 2017 by Shrisun
@poVoq before backup, take your site to maintenance mode then do rest.
commented Dec 25, 2017 by chinnailu
Nice work Scott ! Thank you.   I have recently upgraded my site to PHP 7.1 and it fails. I moved to 1.8 beta 2 as well, some issue. I have captured the issue at http://www.question2answer.org/qa/61535/http-error-500-after-php-7-1-x-upgrade , would be great, if you can have a quick look and advise.
commented Dec 28, 2017 by ProThoughts
nice Scott! thanks for the release.
commented Dec 30, 2017 by Yogendra Basnet
Thanks Scott. Eagerly waiting for stable release.

1 Answer

+4 votes
answered Jan 1 by Scott
Official release is now up on the Q2A website. Happy new year!
commented Jan 1 by fara
Thank you Scott and happy new year. :)

The first thing I see is the tag cloud widget which still doesn't work correctly. And still I think this works fine:
http://question2answer.org/qa/49272/suggestion-about-most-popular-tags-widget?show=49287#a49287
Why don't you try the above code?
commented Jan 1 by ProThoughts
Thanks Scott, Wish you a very happy new year!
commented Jan 5 by bluegenel
Thank you Scott. You are doing an excellent and much appreciated job.
...