Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+2 votes
165 views
in Themes by
I intergrated a background attribute on my Q2A headings (h1, h2, etc) and all are good exept the question page title. There seem to be a line causing the background to stop short. Any body know what I am to do to remove this line (or correct this).

URL to an example: http://www.satechhelp.co.za/index.php?qa=1350&qa_1=are-the-galaxy-young-%26-pocket-plus-lcds-cross-compatible - "1 Answer" & "Related questions" are good. Many thanks
Q2A version: v7.1

1 Answer

+1 vote
by
selected by
 
Best answer

You could try adding an exception for your h1 tag for the question view page. Something like this:

.qa-template-question h1 {
    padding: 0 25px 29px 0;
}

Edit: Remove the previous change and apply this one:

.qa-main h1:first-of-type span.entry-title {
    float: none;
}

Result:

by
h1 {
    font-size:24px;
    margin:0 0 25px;
        line-height:1.1em;
    border-bottom:1px solid #bfbfbf;
    position:relative;
    padding:0 25px 5px 0;   
}
.qa-template-question h1 {
    padding: 0 25px 29px 0;
}

I added the suggested as per the above and it seems to work for the first question title line but any part that falls on the following line of the title goes without the border.
by
Ok. Remove my previous suggestion and add this one:

.qa-main h1:first-of-type span.entry-title {
    float: none;
}
by
And that did it! Any quick suggestion on what I can modify to make sure the text and the border do not start at the same point  e.g.    [  Are the Gala....
Many thanks for the above assistance!
by
.qa-main h1:first-of-type {
    padding-left: 8px;
}
by
Thanks a million - that worked too!
...