Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+2 votes
112 views
in Q2A Core by

New install on Linux Debian 11.

Attempted to add a question category when logged in as Admin but only a blank page is returned after clicking the 'Add Category' button.

Also unable to set the admin's Avatar by uploading a .jpg.  I mention this should the two be connected.

Tried to find what the file permissions should be set to. My first thought was to verify all file permissions were correct.

Anyone know the recommended file permissions for a new install?

Q2A version: 1.8.6
by
Your web server log should contain more information about what's going wrong. Default permissions from extracting the zip archive (owner root, mode 0644) should work just fine. Avatars are stored in the database by default, so file permissions shouldn't matter there. So, as already stated, please check your web server logs.

1 Answer

+1 vote
by
selected by
 
Best answer

I guess you're using PHP 8. If that is the case, then try this fix.

Anyway, if you are in PHP 8, you will face other issues as well. I'd advice you to use this non-official branch, which I've been maintaining for this PHP version.

by
Brilliant, thanks.  I did have that site using PHP 8.0. Changed it to PHP 7.4 and all is well.

Pure joy to have such a simple answer every so often.  :)
by
Could you share with me please how did u fix this problem? Because i have same thing, what should I do step by step, please?
by
Remove red lines. Add green ones.
by
it really works, thank you so much bro, I was correct when I asked you a fix for this problem, thank you again bro
by
I glad see you've already solved your issue.

Just FYI I've been using ISPConfig for years to manage servers, accounts and so forth. With ISPConfig one selects the version of PHP one wants to run on each website/domain.

ISPConfig is OpenSource and free to use. I've always found it to be solid and the support on their forums is very good indeed. https://www.ispconfig.org/
...