Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
0 votes
4.3k views
in Q2A Core by
edited by
I just installed ver 1.5.1 but avatar does not appear on the questions list page (front page) it only appears on the question view page.

Note: I enabled Allow Gravatar avatars option + Allow users to upload avatars + I uploaded default avatar.

 I reinstalled Q2A and got the same problem - no avatar.

any help will be appreciated. Thanks,
Q2A version: 1.5
by
It should work, I have no problems. Did You set a pixel width for the avatar on questionlists as well ?
Try to upload a smaller sized avatar as well, lets say 20 kb, so You can see if it is due to limited resources at least.
And clean Your cache, may be the browser did not update after enabling avatars.
by
edited by
Thank you monk333. I tried all kind of scenarios but none of them worked. The problem is I'm able to see the avatar on the question view page and not on the question list page(main page). I even reinstalled the whole thing couple of times.

2 Answers

+1 vote
by

Can you please download the latest version (just released):

Mar 18: Q2A 1.5.1

Also, if I'm not mistaken, there should be a option in Admin to enable/disable that sort of metadata on the question list.

 

+1 vote
by
See the "Avatar size on questions lists" setting in the 'Users' section of the admin panel.
by
Looking good now. My bad, the image (in the questions list page) pixel is set to zero by default. I overlooked the option.
...