Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+2 votes
567 views
in Q2A Core by
retagged by
Firstly sorry for my english..

Point system is workly fine..

But when i add a point manually its not working correctly..

For example : user has 100 point

I am opening a random user then add +40 point ( first manuel point add works always fine but then.. ) last point : 140

Then -40 point last point is 70 ?!?!

Then +30 point last point is 110 etc..

Whats that ? anybody know that ?
Q2A version: 1.7

3 Answers

0 votes
by
anybody know that ?
+1 vote
by
edited by

Bonus points will be simply added to or subtracted from current (pure) total point of specific user. Current (pure) total point of specific user will be displayed by changing bonus point = 0. However, while you are working, if any user is logged in and performing some operation (vote, etc), total point of other user might change. So, if you want to set bonus points based on current total point exactly, you have to operate after setting "Admin" > "General" > "Take site down for temporary maintenance".

0 votes
by
firstly thx for your answer..

But i try your solutions.. but its now working.. i take the site maintenance then i try but its the same..

i try this my another q2a site.. its not woring too..
by
Try next operation.
1) "admin" > "Stats" > "Delete hidden posts"
2) "admin" > "Stats" > "Recount posts"
3) "admin" > "Stats" > "Recalculate user points"

If you still the same phenomenon occurs, try to calculate manually with information below.
A) Look at several options in "admin" > "Points"
B) Calculate "points" field in qa_userpoints table manually.
...