Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+1 vote
161 views
in Q2A Core by

I have changed the website provider and copied my old Q&A tables and files to the new server. Then I changed the config file to the new values. So far so good but when I call the page I get at first this message:

Your Question2Answer database needs to be upgraded for this version of the software.

and when I click on upgrade I get this message:

Running query: LOCK TABLES qa_userlevels WRITE, qa_userfavorites WRITE, qa_usernotices WRITE, qa_userevents WRITE, qa_sharedevents WRITE, qa_cookies WRITE, qa_categories WRITE, qa_pages WRITE, qa_widgets WRITE, qa_posts WRITE, qa_blobs WRITE, qa_words WRITE, qa_titlewords WRITE, qa_contentwords WRITE, qa_tagwords WRITE, qa_posttags WRITE, qa_uservotes WRITE, qa_userpoints WRITE, qa_userlimits WRITE, qa_iplimits WRITE, qa_options WRITE, qa_cache WRITE, qa_usermetas WRITE, qa_postmetas WRITE, qa_categorymetas WRITE, qa_tagmetas WRITE ...

2 upgrade step/s remaining...

Question2Answer was unable to perform the installation query below. Please check the user in the config file has CREATE and ALTER permissions:

SHOW COLUMNS FROM qa_messages

Error 1146: Table 'dbxxxxx.qa_messages' doesn't exist

 What could be the reason? I have version 1.7.0

Q2A version: 1.7.0

1 Answer

0 votes
by
you make in the new db server an user and passwork like in the old server?

maybe that is the reazon
...