Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.

HTTP ERROR 500 with 'Ask Question'

0 votes
195 views
asked Apr 2 in Q2A Core by ranse

I upgraded my server to PHP 7.1.x. After the upgrade when tried to submit a question ( with version 1.8.0), it throws below HTTP error. All other functionalities seem to be working fine.

This page isn’t working
cleartalking.com is currently unable to handle this request.
HTTP ERROR 500

I found the below answer to the same scenario.

------------

The error was Curl module was missing. and it was enabled to fix the below error in the trace. 

PHP Fatal error: Uncaught Error: Call to undefined function curl_init() in /home/xxx/public_html/qa/qa-plugin/akismet-spam-filter/akismet.class.php:74 
Stack trace:

----------

Per above suggestion, I checked for Curl module in my server and that also enabled. Can someone help to fix this issue?

Q2A version: 1.8.0

2 Answers

0 votes
answered Apr 5 by Luis74
the plugin does not support php version 7.X
Or you make the PHP dowgrade to version 5.X

Or remotely the plugin
commented Apr 6 by diginot
i use php 7.0.29 and Q2a 1.8.0 and working
0 votes
answered Apr 7 by ranse
I had multiple such  issues when upgraded from 1.7.4 to 1.8.0. Troubleshooting for a while, decided to delete the Q2A folder with 1.7.4 completely and copied vanilla 1.8.0 files.  After this by keeping the database that worked with 1.7.4, ran the upgrade for 1.8.0 as prompted. This fixed all the issues and none of the error messages appear any more.

Once the upgrade completed, copied the latest versions of all the needed plugins. No issues so far.
...