Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+1 vote
76 views
in Q2A Core by
reopened by

Q2A version: 1.8.2
by
I bet this was not the first time you've tried to upgrade to 1.8.2, right?
by
Not 1.8.2, v.1.8 yes.
by
Is there any way I could fix it?

1 Answer

+2 votes
by
selected by
 
Best answer

Installation has failed at some point. Then you tried installing and now it is failing earlier because your database is in an inconsistent state. Knowing the original error would be useful to see in which step the original installation failed. As you don't remember that for sure, you'll have to go step by step.

1. Locate this line and comment it adding two slashes ( // ) at the beginning of the line

Retry the installation and report back (copy/paste the red text as a comment) here.

by
My bad. I linked you to the wrong line. Remove that comment. Check the link again and retry. Don't comment the next one. Unless you also get an error in the next one. Then report back :)
by
It went through, I just had to comment the next one as well, coz I got the same error for that one too.
by
Database successfully updated:

After->
https://i.postimg.cc/DZJSzspD/1.png
by
+1
Excellent! Nothing better than starting a new year with the latest Q2A version installed :)
...