Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
0 votes
149 views
in Plugins by

How to install the plugin of the ElasticSearch? After installation to the ElasticSearch, there has a bug and show the error message as below:

Deprecated: filter_var(): explicit use of FILTER_FLAG_SCHEME_REQUIRED and FILTER_FLAG_HOST_REQUIRED is deprecated in /www/wwwroot/abc.com/qa-plugin/q2a-elasticsearch-master/es-client/vendor/elasticsearch/elasticsearch/src/Elasticsearch/Client.php on line 1547

Fatal error: Uncaught Elasticsearch\Common\Exceptions\Serializer\JsonErrorException: Syntax error in /www/wwwroot/abc.com/qa-plugin/q2a-elasticsearch-master/es-client/vendor/elasticsearch/elasticsearch/src/Elasticsearch/Serializers/SmartSerializer.php:93 Stack trace: #0 /www/wwwroot/abc.com/qa-plugin/q2a-elasticsearch-master/es-client/vendor/elasticsearch/elasticsearch/src/Elasticsearch/Serializers/SmartSerializer.php(64): Elasticsearch\Serializers\SmartSerializer->decode('') #1 /www/wwwroot/abc.com/qa-plugin/q2a-elasticsearch-master/es-client/vendor/elasticsearch/elasticsearch/src/Elasticsearch/Transport.php(171): Elasticsearch\Serializers\SmartSerializer->deserialize('', Array) #2 /www/wwwroot/abc.com/qa-plugin/q2a-elasticsearch-master/es-client/vendor/elasticsearch/elasticsearch/src/Elasticsearch/Endpoints/AbstractEndpoint.php(85): Elasticsearch\Transport->performRequest('HEAD', '/q2a-elasticsea...', Array, NULL) #3 /www/wwwroot/abc.com/qa-plugin/q2a-elasticsearch-master/es-clien in /www/wwwroot/abc.com/qa-plugin/q2a-elasticsearch-master/es-client/vendor/elasticsearch/elasticsearch/src/Elasticsearch/Serializers/SmartSerializer.php on line 93

Please help and advise.

Thank you.

Q2A version: 1.8.5
by
Check ur elasticsearch whether is running. View localhost:9200 in brower.
To install a plugin (requires Q2A 1.3 or later), place its directory in Q2A’s qa-plugin directory, then open the Plugins section of the Admin panel and check it is listed. The plugin may also offer some options on this page.
by
The plugin can work on CentOS 8.2?
by
Hi there, I've updated the plugin with the newest ES. Check it out here: https://www.question2answer.org/qa/90944/elasticsearch-improve-feature-powerful-scalable-search-engine
and let me know if you have any issue!

Please log in or register to answer this question.

Welcome to the Q&A site for Question2Answer.

If you have a question about Q2A, please ask here, in English.

To report a bug, please create a new issue on Github or ask a question here with the bug tag.

If you just want to try Q2A, please use the demo site.

April 20, 2021: Q2A 1.8.6 released!

Categories

...