Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+1 vote
86 views
in Q2A Core by
closed by
PHP Warning: count(): Parameter must be an array or an object that implements Countable in /var/www/vhosts/xxx.xxx/httpdocs/qa-include/qa-base.php(720) : eval()'d code on line 89', referer: https://www.xxx.xx/admin/mailing
Q2A version: 1.8.6
closed with the note: Resolved
by
+1
I don't know the answer but here are some shots in the dark:
- If you have not made any changes to the code, then download it again and compare if any files have been accidentally modified.
- Did you edit qa-base.php?  There is an eval() call at 720 and a count() call at 750.  If you have edited the file, then probably there is some missing quote or parenthesis or semicolon.
- Are you using any third party plugins?  Couple of them I got are old and don't work well with 1.8.6.  I had to make changes to them to make it work.  Although, I did not see this particular error.  You can try disabling the plugins one by one and see when it starts working.
- Use error_log(print_r($<variable>,true)); to print the 'variable' in question to make sure everything is in order.  You'll have to enable LogLevel to 'debug' in apache2.conf and restart the service.
by
+1
You'll have to provide a link to all the plugins you have installed in your server (assuming they have not been modified). Alternatively, if you know how to reproduce it, just remove the plugin directories one by one until the issue is no longer reproduced. Then, provide the link to that repository (only)
...