Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+3 votes
90 views
in Plugins by
I have been using PHP 7.3 version just because Google Captcha default plugin in Q2A does not work with 7.4 version. But since PHP 7.3 is no longer supported after 6 December 2021, it isn't safe to use 7.3 for the security of the site.

When using captcha on php 7.4, it just keeps giving this error "Please complete the anti-spam verification", even when Google shows a green tick sign next to "I am not a robot" when you click it.
Q2A version: 1.8.6
by
After researching a little, it seems I have to enable allow_url_fopen in php.ini for recaptca to work, which I think isn't safe. I will try to modify the plugin code for this to work without allow_url_fopen.
by
Does anyone have code for cURL method for recaptcha?
by
What value have you set to the allow_url_fopen setting in your php.ini files? (Please, check both of them)
by
I decided not to enable "allow_url_fopen" in php.ini due to security risk. I replaced the Google recaptcha plugin with q2apro-stop-spam-master plugin.

Please log in or register to answer this question.

...