Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+2 votes
611 views
in Q2A Core by

I couldnt install Q2A 1.5 beta on localhost , please help , thank you very much

when enter localhost:82/q2s/install

 

 
by
Are there any entries in your web server error logs?
by
everything is working alright, except q2s script. i have tested q2s script on both wamp and vertrigo but couldnt run with same errors. i search on internet errors "Error 330 (net::ERR_CONTENT_DECODING_FAILED): Unknown error". they said script require  zlib

When i turn on  zlib , i can enter http://localhost:82/q2s/ but some errors  still display
by
i have installed 1.4.3 version again , and its working well. is it 1.5 beta require some new thing ?
by
edited by
Notice: Use of undefined constant QA_DEBUG_PERFORMANCE - assumed 'QA_DEBUG_PERFORMANCE' in D:\VertrigoServ\www\q2s\qa-include\qa-index.php on line 35

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at D:\VertrigoServ\www\q2s\qa-include\qa-index.php:35) in D:\VertrigoServ\www\q2s\qa-include\qa-app-users.php on line 128

 Warning: Cannot modify header information - headers already sent by (output started at D:\VertrigoServ\www\q2s\qa-include\qa-index.php:35) in D:\VertrigoServ\www\q2s\qa-include\qa-app-users.php on line 174

Warning: Cannot modify header information - headers already sent by (output started at D:\VertrigoServ\www\q2s\qa-include\qa-index.php:35) in D:\VertrigoServ\www\q2s\qa-include\qa-page.php on line 329
by
OK, I understand the problem. It's a bug in 1.5 beta, where the QA_DEBUG_PERFORMANCE constant is referred to before it is defined. For now you can just fix this by editing qa-include/qa-index.php to replace QA_DEBUG_PERFORMANCE with false (unless you do, in fact, want to debug performance).

1 Answer

0 votes
by

New errors display
 

by
OK, for this it looks like you should switch off QA_HTML_COMPRESSION in qa-config.php.
...