Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
0 votes
682 views
in Plugins by

Not sure what happens. In my Google Webmaster Tools I have over 50 Crawl Errors. 

Any changes in xml-sitemap plugin. Google found links like a (error of course):

questions/register?to=

or

questions/literatura/czym-jest-quask-pl

where 'literatura' is category and 'czym-jest-qask-pl' is custom page (not plugin, just standard page created in admin).

I have other Q&A sites, and no problem like this. Any idea what happens?

Q2A version: 1.5.1
by
You mentioned sitemaps there, are the non-existent pages coming from the sitemap?
If they are regular crawl errors it should tell you the page that links to those URLs.
by
no, sitemap is ok. No idea how these links are created. This error is with by me created link, but also with register?to= as you see. Strange.
by
What is the site URL? Is it the one in your profile, as you don't have a 'literatura' category there.
by
this is http://qask.pl/ New one
by
Looks like a fixed now. I selected all errors as 'fixed' in webmaster tools. But also, I had link on all pages in "welcome module" this yellow one. It was <a href="czym-jest-qask-pl">czym jest qask.pl</a>
Now link is <a href="../czym-jest-qask-pl">czym jest qask.pl</a> maybe it maked error, but should not.
by
More. I think, this is bug. I found again broken link.
This is category page (empty now):http://qask.pl/questions/prawo-i-finanse/prawo
and here q&a generating link: http://qask.pl/questions/czym-jest-qask-pl
where should be http://qask.pl/czym-jest-qask-pl of course.
link source is <a href="../czym-jest-qask-pl">czym-jest-qask-pl</a>, and should be ok, but is not. I will change it now to <a href="http://qask.pl/czym-jest-qask-pl">czym-jest-qask-pl</a>

Please log in or register to answer this question.

...