Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+1 vote
20.6k views
in Q2A Core by

Tried to use the xml sitemap plugin or the example plugin.

 

If you will go the the plugin page there is only a link to the admin menu.

"Edit custom page"

 

Could you help?

 

Oliver

by
Can you please provide a link so I can see this?
by
Hello,

sorry I could not, because the page is in a private network :(

But I can provide the HTML Source of the page output:

    </UL>
                    <DIV CLASS="qa-nav-main-clear">
                    </DIV>
                </DIV>
                <DIV CLASS="qa-nav-sub">
                    <UL CLASS="qa-nav-sub-list">
                        <LI CLASS="qa-nav-sub-item qa-nav-sub-admin/pages">
                            <A HREF="./admin/pages?edit=1" CLASS="qa-nav-sub-link">Edit custom page</A>
                        </LI>
                    </UL>
                    <DIV CLASS="qa-nav-sub-clear">
                    </DIV>
                </DIV>
                <DIV CLASS="qa-header-clear">
                </DIV>
            </DIV> <!-- END qa-header -->
           
            <DIV CLASS="qa-sidepanel">
                <DIV CLASS="qa-sidebar">
                    Willkommen,<br>

1 Answer

0 votes
by
edited by

Yes, this is was bug in the original 1.3 beta 1 release. It occurred if you added a navigation link to a page which is provided by a plugin. If you downloaded 1.3 beta 1 within the first few hours, you can fix it by modifying this line in qa-page-home.php:

if (isset($categoryslug) && isset($custompage)) {

... to ...

if (isset($categoryslug) && isset($custompage) && (!($custompage['flags']&QA_PAGE_FLAGS_EXTERNAL))) {

Since this was caught so quickly, I've replaced the current 1.3 beta 1 download with a fixed version.

by
Thank you :)
by
I can confirm that the above patch is working on our site.
Thx
...