Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+1 vote
886 views
in Plugins by
On Site Notification doesn't work in IE and Chrome but it works in Firefox. What should I do?

Q2A version=1.6.3 and Theme=snow
Q2A version: 1.6.3

1 Answer

0 votes
by
selected by
 
Best answer
If you have:

- q2a version 1.6.3 installed

- default Theme snow chosen

- made no modifications

the on-site-notifications are working.

If not, there is something wrong with your setup.

Continue debugging here: https://github.com/q2apro/q2apro-on-site-notifications/blob/master/CONTRIBUTING.md
by
@q2apro.com: Thank you. on-site-notification shows the number of events and the color of box is changing to yellow, but it doesn't open after clicking!
by
Then check the web console for javascript errors. If there are none, check if the DIV #nfyWrap has been inserted by javascript.
by
I found that it works when I delete www at the beginning of my domain!But with www it doesn't work!
by
Check table qa_options if the field "site_url" matches your URLs.

Furthermore, use htaccess to rewrite all domains to www.

Example htaccess:
# Rewrite all domains/xyz -> www.q2apro.com/xyz
RewriteCond %{HTTP_HOST} .
RewriteCond %{HTTP_HOST} !^www\.q2apro\.com [NC]
RewriteRule (.*) http://www.q2apro.com/$1 [R=301,L]
by
Thank you kindly for your help. :)
by
@Kai
this tip on htaccess should be added to your readme or something
by
Good idea, added info to the contribution file: https://github.com/q2apro/q2apro-on-site-notifications/blob/master/CONTRIBUTING.md (currently n° 11 + 12)
by
much better, thank you
...