Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+1 vote
582 views
in Q2A Core by
edited by

How stable is the dev branch of q2a I can get here?

https://github.com/q2a/question2answer/tree/dev

Can I use this version for an productive system or shoud I use Version 1.6.3?

I want to start my q2a site but I'm not sure when!?

Wating for 1.7 or use 1.6.3 (with mysqli db file)

by
If you want to use free themes, the new SnowFlat theme, included in 1.7 is very good.

2 Answers

+3 votes
by

How stable is the dev branch of q2a I can get here?

I hardly believe there is an answer to that question. How do you measure stability?

Can I use this version for an productive system or shoud I use Version 1.6.3?

Yes, you can use 1.7alpha1 in a productive system. Furthermore, there actually are bugs in 1.6.3 that have been corrected in 1.7alpha1. What nobody will be able to ensure is that there aren't any bugs in 1.7alpha1 :)
 
Note that 1.7 won't have radical changes. Mostly bug fixes and relatively isolated changes such as the private message inbox. The most critical thing would be the changes to mysqli, which you claim you will be using anyway so I would go for 1.7alpha1 anyways.
 
Also, bear in mind you could start with 1.6.3 and then upgrade to 1.7alpha1.
 
What I wouldn't do if I were in your shoes is waiting for the 1.7 release as there is no release date set.

 

+3 votes
by
This is my opinion.

Main developer has changed from V1.7. And, release is late. The current development version there are some issues. If you do not plan to use existing plugins, it is also possible to upgrade when the stable version of V1.7 has been released in future. However, follow-up of plugins take time. So, V1.7 to help in actual use (including plugins) will be much later.

If you will publish Q2A site with server on the Internet, you should select V1.6.3.
...