Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+1 vote
1.3k views
in Q2A Core by

hello

i try to update my script from 1.6.3 to 1.7 beta 2

i got this err0r

Fatal error: Class 'mysqli' not found in /home/soual/public_html/qa-include/qa-db.php on line 66

any heelp

!!

Q2A version: 1.7 beta 2
by
What version of PHP are you using? You can find it on the admin/stats page. Or do this in a separate script to see:
echo phpversion();
by
Pro http://soualwjoab.com/info.php

PHP Version 5.4.20
by
According to that you have mysqli installed (which it should be, it's standard on all PHP installs).

Does it work if you just call mysqli in its own script? e.g.
$mysqli = new mysqli('localhost', 'my_user', 'my_password', 'my_db');
or
$link = mysqli_connect('localhost', 'my_user', 'my_password', 'my_db');
by
after i install mysqli it is work fine , thanks

1 Answer

+4 votes
by
selected by
 
Best answer
Just answering this for posterity in case anyone else has the problem :)

OK so the answer was to install mysqli. But it should come pre-installed on most hosts.
...