Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+1 vote
386 views
in Plugins by
edited by
I built a very simpĺe plugin to remove the categories from the panel side. I discovered that when I used it, FAQ plugin wasn't working. So I started commenting parts of my plugin and I realize that it is the lang files that are providing the conflict and when I comment the line, everything works well. Ok... These lang files are only there by completeness. They are useless, since their content is only useful for administrators. So the problem is easily solvable. However, I would like to understand the problem. My plugin is at

If I comment this line https://github.com/danielcajueiro/Q2A-Remove-Categories-From-Side-Panel/blob/master/qa-plugin.php#L24 everything works.
Q2A version: 1.7.0

1 Answer

+2 votes
by
selected by
 
Best answer

I downloaded the code, uncommented the line, navigated to the home, FAQ page and admin settings and everything seems to work. I tested it on Portuguese and English. No issue at all.

As a side note, this code in the layer:

if(isset($this->content['navigation']['cat']))
    unset($this->content['navigation']['cat']);

Is the same as:

unset($this->content['navigation']['cat']);

by
Thank you! So, what must be happening here? I tested several times!
by
As I said, I only get the expected behavior so nothing wrong seems to be happening. You haven't mentioned any particular error rather than "FAQ plugin wasn't working" so there isn't much I could do.
by
Thank you! I will spend sometime improving my debugging and errors exposing system!
by
Finally, I am testing my Q2A site alive. I didn't find this issue as well. This is really strange. Thank you again!
...