Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
0 votes
354 views
in Q2A Core by

This is my first Q2A installation so I might be mistaking something obvious, still I'd really appreciate if anybody can help.

I created the database and installed the bundle as requested, I reached the appropriate folder address and the admin set up screen showed up as expected. I created a super admin ID and logged into my Q2A installation but... as soon as I tried to save the first admin screen, the system freezed and I was not able to log in anymore: not through my ftp client nor even from OnlyDomains cpanel interface.

I already contacted Only Domains and they helpdesk told me the system blocked for some (still unverifiable) reason any access. I have them unblock the whole and re-installed everything, just to to end up stucked in the same situation.
Only Domains replyed that:

OnlyDomains Support: If Q2A requires special access (such as database access or root access) that may be the cause of the block -- root access is not available on our platform for security reasons.

Do you guys believe I should change host either is there any other possible cause for this type of problem?

Thanks in advance to anybody willing to answer

 

Q2A version: 7
by
Does the server have Apache ModSecurity installed?
by
moved by
Hi Scott,
yes it does... is.it good or bad news :,-o?
by
I prepared sites with a htaccess and published them without any problem. You must not give too much importance to the generic answer of the hosting service. A common error is to forget to change the paths or database host and rights ( mysql root ? )

1 Answer

0 votes
by
OK I think the issue is the same as here: http://www.question2answer.org/qa/44860/serious-web_attack-ldap_injection-error-owasp-modsecurity

The mod_security module blocks access to the server when you access a URL with certain characters. Can you try the solution there (editing admin-default.php) and let me know if it works?
...