The only issue of using newer versions of PHP 5.x with 1.6.3 and below is the mysql functions deprecation in favor of the mysqli ones. However, that happened on PHP 5.5 so you should be fine up to 5.4. Anyway, you can safely upgrade even to 5.6 (latest 5.x version so far) but will have to remove the warning editing your php.ini file.
Regarding using old versions of Q2A, I think there is no reason to do so. Upgrading to 1.7.4 will get you new features, security fixes, bug fixes and better support.