Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+2 votes
40 views
in Q2A Core by

i got this error when trying to post , please check: 

Q2A version: 1.8.6
by
That's unreadable. Please copy and paste error messages *as text*, not screenshots.
by
Uncaught SyntaxError: Unexpected token '<'
qa-global.js?1.8.6:610 Uncaught ReferenceError: qa_cat_maxdepth is not defined
    at qa_category_select (qa-global.js?1.8.6:610)
    at ask:144
    at dispatch (jquery.min.js:2)
    at v.handle (jquery.min.js:2)

it is like this
by
Are categories enabled on your site? (in Admin > General > Question classification)
by
There's not much information about the issue but it seems more related to a faulty theme or a plugin. You can try this plugin and share some additional information about your site: https://github.com/pupi1985/q2a-pupi-coma (even the bare minimum should be enough)

A few more questions:
1. What URL are you trying to access? (e.g. the "/ask" page)
2. Do you see the "qa-src" directory in the root of Q2A (at the same level of the "qa-include" directory")?

Please log in or register to answer this question.

...