Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+1 vote
297 views
in Plugins by
edited by

This question helps you with:

  1. After updating Q2A or upgrading the PHP version of my website, a Plugin is now outdated and is throwing an error.
     
  2. How to detect which plugin is in conflict with my theme or vice-versa.

1 Answer

0 votes
by
edited by
 
Best answer

How to debug / narrow down plugin conflicts?

If the PHP thrown error is not specific enough, here's a few steps you can do, to help you narrow down the source.

  1. Disable all of the non-default plugins (Remove the ones that cannot be disabled) and start from the beginning, with your theme only installed.
     
  2. Start adding plugins, and activating them one by one.
    As you activate one, refresh your website to see if it's still working properly.
     
  3. As you're adding more plugins, activating and checking your website, eventually you'll find the one plugin that's causing a conflict.
     
  4. Now you have a more targeted view of where the problem is, you can either: 

    a) Create a more targeted question of what the problem is, including valuable information such as the gitHub link for the plugin, if it's free.

    b) Contact the developer and ask for help, if it's a premium product.

...