Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+2 votes
781 views
in Q2A Core by
For about 2 weeks my site and email system was working flauesly.  Suddenly even me (the super admin) cannot receive any emails, they are sent to spam box.

I checked and the IP address of my server is spam-blocked (don't know when this happened).  Even if I clear it, I know it may happen again in the future, as this is a shared hosting account.

Will it help to setup the SMTP with a GMAIL account?  Will it work around this problem?
Q2A version: 1.6.3
by
For 2 usd per month I can get a separate dedicated IP address from my host.  Would this be a better solution?

2 Answers

+2 votes
by
I'm not sure that a dedicated IP address will be of help for you.
I could be wrong, but the email server will probably continue to use the shared IP, even if you buy a dedicated IP.
You could avoid the issue only migrating to a dedicated server or VPS (at higher costs,  of course). Probably only in this case your associated IP will be used by the SMTP server.
About using the google smtp, the access to third party SMTP servers could be blocked by your provider. If it's not, you could give a try to it.
But you have to inform your hosting provider's support about what's happening.
And since the issue could be solved only after weeks, I would ask your provider to be moved (at no cost) to a new shared server not affected by the blacklisting issue !
(of course I suppose you are not the cause of the blacklisting smiley )
by
AFAIK I do not cause the blacklist, unless my sites are infected and I do not know this.  I mean, if my Q2A is infected, how can I know?  I do not send any spam anyway.

Even if they move me to a clean server, it may be blacklisted in the near future.  Shared hosting is a problem.
by
Go here :
http://multirbl.valli.org/
and run the test "test by sending an email" using an account defined on your current smtp server.
You should contact immediately your hosting provider too.
by
Just to know, did you run the test above ? In case you did, which was the output ?
by
I just did and it came out clean.  BUT my host was quick and had already delisted the IP address.  So when I tested again now at http://www.spamhaus.org/lookup/, it also came out clean.  My mails do not go to spam any more.
by
Glad to know you solved your blacklisting issue so quicky
0 votes
by

Did you checked IP and your domain in this site?

by
This tool says:

This IP address is infected with, or is NATting for a machine infected with the ZeuS trojan, also known as "Zbot" and "WSNPoem"......
by
Read my answer (question for you) again.
by
I had tested my domain and came out clear.

The host replied that the message indicated there was an exploited domain on the server that sent spam mail.
by
Good. I think that server administrator will deal, but if that can not be dealt, dedicated IP is valid. Good luck.
...