Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
0 votes
3.3k views
in Q2A Core by

This is what happens when a mail is supposede to be sent. (feedback form, confirmation mail for account, etc..)

I use external SMTP and everything is correct for settings, so I have no clue where can the problem be in Question2Answer.

---------------------------------------------------------------------------------------------------------------

Question2Answer fatal error:

Could not send email confirmation
 
Stack trace:
 
require() in index.php:31
require() in qa-index.php:175
qa_get_request_content() in qa-page.php:789
qa_call_override() in qa-page.php:198
qa_call() in qa-base.php:579
qa_get_request_content_override_1_in_qa_cv_overrides_php() in qa-base.php:532
qa_get_request_content_base() in qa-base.php(510) : eval()'d code:9
qa_call() in qa-base.php(577) : eval()'d code:1
qa_get_request_content() in qa-base.php:532
require() in qa-page.php:207
qa_send_new_confirm() in qa-page-confirm.php:54
qa_call_override() in qa-app-users-edit.php:244
qa_call() in qa-base.php:579
qa_send_new_confirm_override_1_in_overrides_php() in qa-base.php:533
---------------------------------------------------------------------------------------------------------------
 
Any idea in how to fix it ?
 
Thank you.
Q2A version: 1.6.3

1 Answer

+1 vote
by
The use of an external SMTP service could be blocked by your provider.

Try first to use your provider's SMTP service using real (=defined in your domain's Cpanel) email addresses for the "sender address" and the "email address for the admin messages"
by
I tested that before and shows me that there is no connectivity issue between the server and the mailgun server:

# telnet smtp.mailgun.org 465
Trying 50.56.21.178...
Connected to smtp.mailgun.org.
Escape character is '^]'.

So the only thing that may have the problem is Q2A. I see there are a lot of threads like this and none of it has a solution.

Thank you.
by
Could you pls post the infos I've requested to you ?
by
The port you should use (see : http://blog.mailgun.com/25-465-587-what-port-should-i-use/) is 587.
If that's blocked, the 2525.

Test them with my php file too.
by
But follow the steps above
...