Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
0 votes
353 views
in Q2A Core by
Hi,

I config my Q2A admin email is tenkana@gmail.com It worked well until yesterday (I received notification email when a question was posted). I asked hosting service provider, here is the answer but I dont understand the solution. So just post here if anybody has the same problem can explain more for me:

-- From hosting provider:

-- 1:

I checked the mail logs, Google seems to have blocked mail from your address due to the 'unusual amount' that it is sending. Are you sending more mail than usual? Do you have the option to use the "-f" switch in your sendmail statement?

Best regards,
Corey

-- 2:

What Corey was describing is a way for you to force sendmail to send mail from a specific address, rather than an address general to the server.

Applications sending mail directly through the sendmail command usually provide some method for you to alter arguments being passed to sendmail. What opensource system are you using? Using this may help ensure deliverability for your email.

Regards,

Bryon

1 Answer

0 votes
by
Well, I'm not quite sure what is going on here either. From what I can tell, though, Q2A does use the -f switch because PHPmailer is coded so it uses it when Sender is properly set; Q2A does this.

How are you sending out your emails? Are you relying on your hosting provider's mail configuration (i.e. doing nothing special) or are you using Google's own SMTP service?

You might find an earlier answer I gave to be useful here:
 

http://www.question2answer.org/qa/2211/can-write-example-modified-file-external-external-emailer
by
Actually i do nothing specially, just fill in my email address in admin section of Q2A and get all done by Q2A send mail function. It worked well in my own host but mails have been sent to spam mail since I moved site to another hosting. (I did not check spam mail so I thought it not work. In fact, I worked but being sent to spam mail)
by
Right. This is because you're not really sending email _from_ Google; you are merely sending email with a from: address mentioning gmail, but using your ISP's mail servers to do it.

Most ISPs will consider this a possible indication of spamming. If you use the solution I mentioned above, your outgoing mail will go via Google's own servers, and you shouldn't have this problem, assuming you can make the required outbound connection from your hosting.

Otherwise, you will need to discuss with your hosting provider whether they will let you send as that email address (they may have some steps to verify that sending address), or send from an email address associated with the domain you are hosting with them.
...