Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
0 votes
125 views
in Q2A Core by
edited by

Hi

It seems that in my website, CKeditor saves in the database the Greek characters with HTML encoding (when the text is formated).  ie, when the text is not formated, everything is saved as plain text.

So the Greek word Ευχαριστώ is saved like Ευχαριστώ

I have checked the database with phpmyAdmin, the HTML codes are there.

I tried adding these to the qa-plugin/wysiwyg-editor/ckeditor/config.js
        config.entities_greek = false;    
        config.htmlEncodeOutput = false;  


They did not help at all.

Here is the page with the problem:
learn-greek-online.com/ask-greek/1158/how-to-address-a-priest

This meta tag is in the head section of the source code of the page:
<meta charset="utf-8">

I am using the default themes.

I tried disabling all the plugins.  The problem remained.

There must be something about my site, since the same problem does not happen in this forum.

Any ideas what I need to do?

Q2A version: 1.8.2
by
Are you using the standard version of CKEditor that comes with Q2A or did you modify it, add plugins etc?
by
No modifications, no plugins.  Whatever came with Q2A.  And I have not changed anything in Q2A core either.

It puzzles me that in this forum it works fine, but in my website, when the text is formatted (Bold, Italics etc), the Greek chars are stored as HTML codes.

I was certain it was caused by some plugin, I did disable all of them, the problem remained.

Thank you for looking into this.
by
@Scott

Any other suggestions?  I still have this problem.
by
Hi Scott

I still have the same problem in 1.8.2.  I am out of ideas.  

Can you suggest something please?

Please log in or register to answer this question.

...