Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
0 votes
487 views
in Q2A Core by

Notice: Undefined variable: locks in/home/ar4v75acf6/domains/wenda.us/public_html/qa-include/qa-db-install.php on line 728

Warning: implode() [function.implode]: Invalid arguments passed in/home/ar4v75acf6/domains/wenda.us/public_html/qa-include/qa-db-install.php on line 728
Running query: LOCK TABLES ... 



Question2Answer was unable to perform the installation query below. Please check the user in the config file has CREATE and ALTER permissions:

LOCK TABLES 

Error 1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1

http://www.wenda.us/index.php?qa=install

how can i install it

 

Q2A version: 1.5.2 chinese

1 Answer

0 votes
by
selected by
 
Best answer
This error is showing up in the upgrade process, so it sounds like you may a previous install which was incompletely deleted. Please try installing on a completely fresh database.
...