Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+7 votes
3.7k views
in Q2A Core by

I am getting this kind of error on my site while sending confirmation mail to new users.

 

Question2Answer fatal error:

Could not send email confirmation

Stack trace:

require() in index.php:31
require() in qa-index.php:165
qa_get_request_content() in qa-page.php:795
require() in qa-page.php:207
qa_send_new_confirm() in qa-page-confirm.php:54

by
Same problem, no issues at this time.... :( Please help :)

3 Answers

0 votes
by
I hope you have it figured out by now. If not then, go to your cpanel and make no-reply@yourdomain.com it should work right away. Make sure to uncheck smpt mail setting.
by
I have the same problem. Could you please make it more detail about how to solve it?
While I developed and tested locally, I did not have a domain email. How can I use it?
Thank you!
by
check your pm...
by
Can you explain it more detail? I still cannot figure it out. What is pm?
Thank you...
by
go into your admin panel, Find Emails tab next to General.

Find where it says (Sender address for the messages from site:)
This is where you have to put in (no-reply@yourdomain.com),  

below this you'll see (Email address for admin messages - not shown to users:)
Use any email address there.

I believe q2a is designed to read no-reply@yourdomain.com as emails send out from the system. I don't know how you'll fix this if you can not make your address as no-reply@yourdomain.com.

how are you hosting your site on your machine?. xampp, wamp, mamp.
by
I used wamp on my machine. We have a server but it's private and we have an IP address that we can access inside our network only. So nothing like no-reply@domain.com

So if I have a mail system in my server, it's gonna be all right, correct?

Thank you for your reply anyway.
by
I believe it will require you to have same domain on your no-reply address to work. When I say same domain I mean where you are installing and can access your q2a site through browser.

If you have mail server, give it a try. See if you can make an email address there with (no-reply@what ever server name.something)

hope it will help you out.

Thanks
by
Hi, I still cannot make it work. Is there anyway to disable the email function?
by
@lyxhaven - PM means "personal message" and is accessible though the options at the top of the screen when you select your profile (top right corner of the screen in this case)
0 votes
by
If you have the same problem, just define $port and $SMTPSecure in qa-class.phpmailer.php.

That's work for me.
0 votes
by
I've had the same issue, and while this is not necessarily the same problem, you clearly have a problem with sending mail through your email server.  My potentially related issue is detailed in the following post, here on Q2As 'help' site.

 

http://www.question2answer.org/qa/50674/im-unable-to-use-email-need-basic-help

 

(This is for anyone else that finds similar issues, since I realize that this user is long-gone!)
...