Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+6 votes
11.4k views
in Q2A Core by
Hi,

I'm getting the following error message at the top of the page while using localhost.

"Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead"

I'm using XAMPP 3.2.1 is this something I need to turn off within Xampp?
Q2A version: 1.6.2

1 Answer

+4 votes
by
edited by
 
Best answer
You are usino PHP 5.5, that has introduced this deprecation :

http://www.php.net/manual/en/function.mysql-connect.php

Since PHP 5.5 is relatively "new" (June 2013) and most sw products have not been tested on it, I would downgrade to PHP 5.4.x.

If you do not want to downgrade you could suppress the deprecation errors by setting error_reporting in php.ini to exclude E_DEPRECATED.

But personally I don't like this solution (you could have other issues)
by
thanks, I edited the php.ini to display_errors=off
by
Thank you max
asked Nov 15, 2014 in Q2A Core by anonymous what can i change in php.ini file
...