Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+2 votes
110 views
in Q2A Core by
edited by

I am already running a q2a successfully without any problems. But yesterday I tried to install q2a on a new domain but email is not working. Even forgot password emails are not working. Feedback form and mailing test emails are showing message server error occured. Forgot password form is showing this error message

Question2Answer fatal error:

Could not send reset password email

Stack trace:

require() in index.php:27
require() in qa-index.php:188
qa_get_request_content() in qa-page.php:47
require() in page.php:183
qa_start_reset_user() in forgot.php:69

I tried both manual install and softaculous install. Both are showing the same errors.

Note: Webmail is working. Mass mailing is showing as complete but not sending any emails.

Q2A version: 1.8
by
One installation on vps which I moved from the shared hosting is working fine. It was working well on shared too. I moved to vps due to login as another user problem.

 But another new  installation on the same shared hosting is not working. I tried installing on another new shared hosting (both manually and using softaculous). Everything works except mails. Webmails, wordpress mails, phpbb mails all are working well on these two shared hostings. Only q2a is having this email problem.
by
what is your q2a site?
by
I moved my new q&a site to another platform https://www.defat.net
by
I recommend you to disable all plugins which dont come with default q2a and see email works.

Please log in or register to answer this question.

...