Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+2 votes
490 views
in Plugins by
Hi,

Q2A-Ultimate-SEO plugin doesn't work in 1.8 Q2A version. Is there any other plugin? I just want some basics: SEO title, meta description, OG: tags (and other social meta tags), featured image... maybe schema org? Thanks.
Q2A version: 1.8.1

1 Answer

0 votes
by
selected by
 
Best answer

AFAIK, there is no other plugin strictly focused on SEO. However, the plugin seems to be working for me: I could install it, change settings and they seem to be reflecting in the site. Note the qa-ultimate-seo directory (which contains the qa-plugin.php file) needs to be a child of the qa-plugin directory.

You might need to clarify what exactly is not working.

EDIT:

Regarding this warning:

Warning: count(): Parameter must be an array or an object that implements Countable in /srv/users/serverpilot/apps/<HIDDEN>/public/qa-include/qa-base.php(725) : eval()'d code on line 160

You should follow these steps to fix it (not it is not an error but rather just a warning):

1. Locate this line

2. Change it to:

if(!empty($this->content['navigation']['cat']) && qa_opt('useo_cat_title_nav_enable')){

by
I am getting this error when I enable plugin:
Warning: count(): Parameter must be an array or an object that implements Countable in /srv/users/serverpilot/apps/<HIDDEN>/public/qa-include/qa-base.php(725) : eval()'d code on line 160
Yes, I put in qa-plugin folder and yes I downloaded latest version from master. I have php 7.1, maybe worth mentioning.
by
I've just explained in my answer how to fix that issue. It is really not a big deal
by
Thank you, that works :) Someone realy should update that plugin.
by
I've just created the pull request for the fix: https://github.com/q2a-projects/Q2A-Ultimate-SEO/pull/14

The author will be able to merge it with just single click :)
by
Hello pupi, your answer does solve one issue and removes a warning showing at the top of the website. But there is one more warning that keeps showing for each tag.

Warning: count(): Parameter must be an array or an object that implements Countable in C:\xampp\htdocs\Gurjyot\q2anew\qa-include\qa-base.php(725) : eval()'d code on line 712

How to deal with this?
by
Same fix. Check the pull request I mentioned above
by
Actually I used that fix and even after that I am getting this warning for tags. One warning for each tag.
The warning at top of website got hidden with the fix but not the warning which I showed above.
by
Have you checked the pull request again? I added the fix
by
Actually I checked the answer above and didn't saw any changes so I replied according to that.

But now I checked the changes in that PR and it worked perfectly. Thank you so much brother...
...