Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+1 vote
75 views
in Q2A Core by

Would it hurt to use jquery-3.5.1.min.js instead of jquery-3.3.1.min.js? 

There are 3 vulnerabilities in jquery-3.3.1.min.js. 

Q2A version: 1.8.3
by
+2
You should upgrade to the latest version of Q2A (1.8.5), it has updated jQuery.
by
Thank you for the answer. Updating is troublesome since I made a lot of changes to the core structure. I will update it when version 1.9 is released.
by
+1
Just save all your changes as a git patch. So, you can easily apply them while updating Q2A.
by
You are absolutely right.

1 Answer

+1 vote
by
go to jquery version change page and see from v3.3.1 to v3.5.1, if there is no breaking changes(I believe there will be no breaking changes). Than go ahead and update to v3.5.1
...