Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+6 votes
2.0k views
in Plugins by
edited by

I am developing a Online User Plugin

Link: http://www.mediafire.com/?ofa4iapl80bk61b

There are two probelm which i am facing in this plugin

1) In qa-online-user-widget.php file on line no. 136 currently i have written direct address to folder img so i dont know how to retrieve address to that folder automatically using any of q2a function.

2) After installing this plugin Voting on questions is showing some error.

 

Can anybody please direct me to right direction  , how to proceed now.

Plugin has been updated at https://github.com/rajul885/online-user-plugin

Thanks

Q2A version: 1.5.1
by
it is a good idea..
by
URL does not work anymore. Here is the new link: https://github.com/iRajul/online-user-plugin

1 Answer

+2 votes
by
Thanks for contributing.

If you would like help, probably the best way to start is to by hosting your code on some cvs site like github.com so we can easily take a look, offer changes, etc.  Otherwise, interactive development easily becomes chaotic.

If you put it on github.com, send me the link and I'll take a look.
by
moved by
by
I would be interest in this also, any progress so far?
by
no progress so far , if anybody tell me what's is wrong then i will update it.
by
can you make a screenshot of your plugin? I've installed your plugin and try to use it (options, widget, etc,.) but nothing happened.
by
First active plugin from admin>>plugin page and then go to admin>>layout and add widget to any area you want.
Note: change line no. 136 of qa-online-user-widget.php to give appropriate address .
Let me know if you find any difficulty.
by
Please check the pull request on github; both issues are resolved for me.  Nice plugin :)
by
Thanks a lot .
by
I get plugin code from https://github.com/rajul885/online-user-plugin

... install it and when I show it in the sidebar, I got the following error:
Warning: Cannot modify header information - headers already sent by (output started at C:\webpub\qa\qa-include\qa-theme-base.php:106) in C:\webpub\qa\qa-plugin\online-user\qa-online-user-widget.php on line 75
1

Could anybody can show me the reason and how to fix ?
by
Try to delete your cookies it may solve this problem.
If it does not solve ur problem ,pls send me a screenshot ?
by
Great! I get it worked on localhost. I will try to run on hosting server and let you know result later.
Thanks a lot.
by
Great Idea. I was trying for it but it show only "1 Online" when we login.
And when I click on it, it shows a message as "Germany 1". What does this message means. Can I remove this message.
...