Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+1 vote
in Q2A Core by

Just tried inline editing with an answer, I can click into the text and edit it. But the save button is missing.

@sama55: Can you confirm please?

I tried it in my local server, but cannot confirm the phenomenon that you say. Can you explain phenomenon in detail?
I post an answer. Afterwards I reload the entire site, click in the text of the answer, I get the CKEditor bar (without Save icon). I can change the text but cannot save it.
Um... I tested it in the same procedure. Save button is displayed, and the text which I changed is stored. Some kind of script error or conflict may occur. Give me much information that I can reproduce phenomenon. For example ...

1. Version of Q2A core
2. Version of CKEditor4 plugin
3. Addon types of CKEditor that you add after
4. Settings of your CKEditor4 plugin

By the way, is error message displayed in your script debugger console?
1. Version of Q2A core: 1.6.3-dev-1203

2. Version of CKEditor4 plugin: CKEditor v1.1.2

3. Addon types of CKEditor that you add after:
toolbarCanCollapse: false,
removePlugins: 'elementspath',
extraPlugins: 'autogrow,savebtn',
height: '400px',
autogrow: true,
resize_enabled: false,
entities: false,
language: 'de',
removeDialogTabs: 'image:advanced;image:Link;link:advanced;link:upload',
linkShowTargetTab: false,
linkShowAdvancedTab: false,
linkShowTargetTab: false,
colorButton_colors: 'F00,11C11D,00F,B700B7,FF8C00,008080,808080,FFFFFF',
colorButton_enableMore: false,

4. Settings of your CKEditor4 plugin:
['Link', '-', 'Image']

5. JS Error. Yes! That one: "TypeError: l is null"

Thanks for your help :)

Please log in or register to answer this question.