Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+3 votes
745 views
in Q2A Core by
How  do you enabale the spell checker ,I seen more then one method here but did not know which one to use, also I need to know the location of the exact file to edit and where exacly to edit the file as in which line....
Q2A version: 1.63

2 Answers

0 votes
by
I dont think that you have to edit any file. Till now there neither there is an inbulit spell checker nor a plugin for that. But if if you want to check your spelling then you can turn on your browsers spell checking. But for all users of your q2a website, there is no such provision till now.
by
It is turned on for mozilla  just not working with ether where you type in the question  in the tool bar or the editior...
+2 votes
by

Interesting....

I'm using the CKEditor4 plugin with q2a 1.6.2.

In the :

Admin-->Plugins --> CKEditor4 ---> "Other Configuration"

I've added on top of all the other lines this setting :

scayt_autoStartup:true

that enables the Spell Check As You Type (SCAYT) embedded CKEditor4 feature.

That is I've changed the default configuration from :

toolbarCanCollapse:false,
removePlugins:'elementspath',
resize_enabled:false,
autogrow:false,
entities:false

to

scayt_autoStartup:true,
toolbarCanCollapse:false,
removePlugins:'elementspath',
resize_enabled:false,
autogrow:false,
entities:false
I've tested it on Chrome, Mozilla and IE and it works....
Thanks for tip smiley
 

ps

the scayt feature is embedded also in the default q2a WYSIWYG editor, but I've not tested it

by
probably you have applied a wrong setting in the CKEditor4 panel configuration ("Other configurations")
by
all I added was scayt_autoStartup:true, at the top as you said, I tried turning on the other features that you check mark at the bottom but they were not working ether...
by
There is a syntax error.
Cut&paste here exactly your settings or post a snapshot.
by
Well I tried to reinstall everything from scratch and only changed  that one thing in the other the ck4 editor was already set by default on two of the settings so I made it the default setting on all of them but it is still doing the same thing, please check your pm...
...