Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+21 votes
11.6k views
in Plugins by
edited by

Hello All ,

I have developed a free and opensource social sharing plugin using which you can share the link in social media

Go and Grab it here.

features

lightweight - No JS or iframes included

powered by font aswome icons

separate text message on home page

different share button options (8 options available . You can choose your favorite one )

textual sharing feature like stacoverflow

template based . Easily you can extend for developers

multiple languages support . You can translate every

Update 1.1 - bugs fixed for vk.com social sharing and few code improvements

Screenshots

1. Colored buttons with icon

2. Colored butons

3. Squared buttons

4. Semi rounded buttons

5. Rounded Buttons

6. Textual sharing like stack overflow

With images like the existing simple social sharing plugin

as a widget (some CSS tweaks may be required for this )

Admin panel -

Hope you will like it .

Please share your idea here so that we can mae it more user friendly .

Note - The project is forked and extended from http://www.question2answer.org/qa/31585/ . I have added much flexibility . So you should use either of them but not the both .

 

Thank you all for your love and support .

Special thanks to @dkd903 . He has encouraged me a lot at the beginning .

Q2A version: 1.6.3
by
v1.0 has been released .
by
Nice plugin... Congratulations...!
by
Thank you @Jatin for your valuable review .

14 Answers

0 votes
by

cant install the plugin. when i add the folder q2a-social-share-master to the website plugin folder (i am using ver 1.6.3) i get the following error:
Parse error: syntax error, unexpected T_STATIC in /home/yoram/domains/lamakama.co.il/public_html/qa-plugin/q2a-social-share-master/opengraph/open-graph-protocol.php on line 162

by
But this error appears to be for PHP versions older than PHP 5.3 . http://stackoverflow.com/questions/4668557/parse-error-syntax-error-unexpected-t-static
by
then i will ask my hosting service
by
Yes my server is using older php version PHP 5.2.17.
by
but this plugin requires minimum 5.3
0 votes
by

I have a following error on my site . at user profile .. 

Undefined index: q_list in //qa-include/qa-base.php(595) : eval()'d code on line 133

could you please tell me , how to fix this error

regards 

...