Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+11 votes
2.3k views
in Plugins by
edited by

This plugin allows loading internal Q2A links using Ajax technology. so pages will be loaded faster and will reduce server resource cost.

Download Link - Github Page

~ All suggestions and feedback are welcomed. also feel free to fork the project and push your useful commits.

~ If you want to use this theme with highly customized themes such as CleanStrap Theme, make sure to set correct element class in plugin's option. for example when using CleanStrap you must visit plugin's option and set "Content Container" field to ".qa-main" instead of ".qa-body-wrapper".


This plugin is in Beta Version and had not been tested by Q2A community. it can easily be removed but if you have a live site, you might want to ask a developer to install and test it for you.

It's normally installed. for more information read project's Github page. also, if you are using a highly customized or advanced theme you might need to change "Page Container" in plugin's option. it's the ID or Class of the element which is used to contain sidebar and main content.

Change Log:

V1.0.1:

  • Support for Back/Forward buttons
  • Issue with incorrect URL is fixed

V1.0.2:

  • Now compatible with Q2A 1.6

This plugin is developed by Towhid from QA-Themes.com. feel free to check our free & open source Q2A plugins & Themes. You can hire us for Q2A Development or theme design.

by
Hi Towhid, would be really great to have a demo at hand :)
by
it works but not good :3
by
@Nguyễn if you could send some feedback about what you didn't like, it would be very helpful.
by
this plugin not compatible for 1.7 version .. -,-

7 Answers

+2 votes
by
I tried it with cleanstrap theme and it doesnt load any page ! the url is changing but not load the page links! Is there any solution on this ??

 

Thanks
by
I made some tests, and it seems that it only works with Neat URLs(first option in "Admin > General" page). It's in queue to be fixed.
by
description is updated, short guide: 1) Visit plugin's page, 2) upload plugin, 3) refresh to get plugin page with plugin's option, 4) open plugin's option, 5) set "Content Container" field to ".qa-main"
0 votes
by
Could you please help me? I would like to see this plugin working !

Best Regards
by
I will create a demo soon.
by
edited by
i tried the plugin on the cleanstrap theme and it doesn't work
 :(
by
I updated description above. short guide: 1) Visit plugin's page, 2) upload plugin, 3) refresh to get plugin page with plugin's option, 4) open plugin's option, 5) set "Content Container" field to ".qa-main"
by
I tried all the steps and now i am getting this error: Fatal error: require_once(): Failed opening required '/mysite/qa-include/app/cookies.php' (include_path='.:/usr/local/php5_4/lib/php') in /mysite/qa-plugin/ajax-page-loader/ajax-pages.php on line 28
by
in the file above ajax-pages.php it requires those files:

        require_once QA_INCLUDE_DIR.'app/cookies.php';
    require_once QA_INCLUDE_DIR.'app/format.php';
    require_once QA_INCLUDE_DIR.'app/users.php';
    require_once QA_INCLUDE_DIR.'app/options.php';
    require_once QA_INCLUDE_DIR.'db/selects.php';

Where are those files ???
by
in "/qa-include" directory. they are some of Q2A core files.
by
I see, it seems that it's a compatibility problem with Q2A 1.6 and older versions(since core files are categorized in directories since Q2A 1.7). I'll make the compatibility check now and update the plugin.
by
check new version, it should be compatible with your Q2A.
by
Thanks for supporting. I will try it as soon as possible and i let you know if everything works fine.

Best Regards
by
edited by
Just tried. Now it opens all the internal links but it has display problems in the question view page. For example 1. if you are in home page and click on a question link It doesnt display the widgets at the side bar. But if i reload the qusetion detail view page with F5 button everything is ok !! It seems that for some reason doesnt loads the widgets

2. It displays twice the footer!

3. it opens the pages very very slow.

PS. Tested on 1.6.3 q2a version with Cleanstrap theme.  I will continue to give feedback here.

Once again thanks for such a useful plugin :)
by
It seems that I should make some changes to CleanStrap theme as well to make them compatible.
by
I tried to use .container instead of .qa-main but has the same result. Doesnt load the sidebar contents.
by
I checked also the firebug error console but there are no errors at all
by
Any update for fixing the issues above on the cleanstrap theme ?? Thanks.
0 votes
by
edited by

I'm learning English, so please help me.

I installed but it works not good.

First:

Admin page is incorrect URL in the browser, because it using the URL like "/admin/etc...". So i think you should:

  • Create a variable var base_url = 'domain.com' 
  • And change pushstate to window.history.pushState({path:base_url + p_url},'',base_url + p_url);

Second:

Something is wrong. When click to some link and it don't appear the header, because I set the main class container is .qa-body-wrapper. The result don't contain the header(menu)

by
the plugin is supposed to redirect to page if it can't load it using Ajax. also some theme's don't use a single container for loading page content(including some of my themes too). it should be fixed.
+1 vote
by
reshown by
Just amazing! You've done a great job!  I'd like to add loading animation .gif image at the center of qa-body-wrapper as in Youtube. Could you tell me please how to implement this option. With it your plugin will be perfect!

Thanks in advance
by
page titles are not changing sometimes.
widget-anywhere's widgets located at main area are also missing.
not showing correctly Blog tool plugin's pages.
so many bugs in this plugin looking forward to stable version
hope you'll fix them all
by
thanks for the report, I'm busy for next 2 weeks. after that I'll make major updates to fix issues and maybe add a few cool features too.
0 votes
by
I can not back Home site. Please check help me ?
+1 vote
by
  • Page title isn't changing when new page opened sometimes.
  • When new page opened, it isn't scrolled to top. if link is clicked in the middle of long page, User has to scroll to top after opening new page.

I'm using 1.7 Snowflat theme

+1 vote
by
any update for this plugin. it seems getting error if I instaled with expandable question list plugin
by
up ...........
...