Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.
+11 votes
2.8k views
in Plugins by

Hi,

I have updated the Android App originally made by NoahY. Here, is the github repo for the Android Studio project.

https://github.com/arjunsuresh/qaoverflow

I had added MathJax support for the questions. 

This is the app available in playstore

https://play.google.com/store/apps/details?id=org.qaoverflow.q2android

It is also possible to make the app custom for your Q2A website. That gives the ability to login via email also (the current one allows only username login). 

Q2A version: 1.7
by
Any improved version of it yet?

1 Answer

+2 votes
by
Hello,

I've installed your application to my device and installed the XML-RPC server. However, I'm getting an 404 error from the application. I've enabled the server but nothing changed. Can you help me? My website is: metudex.com

Thank you very much :)
by
Hi,
For login did you give "username" or "email"? Only "username" works.
by
Yes im only using the admin and password
by
I checked on the app- 404 error should mean the RPC plugin is not correctly installed. Would you mind sharing the admin password with me or just ensure the plugin is working?
by
Please help - I get the following trying to login as Admin (username & pass)

org.xmlrpc.android.XMLRPCException: org.xmlpull.v1.XmlPullParseException: unexpected type (position:END_DOCUMENT null@1:1 in java.io.InputStreamReader@41980208)

at http://satechhelp.co.za

and:

org.xmlrpc.android.XMLRPCException: org.xmlpull.v1.XmlPullParseException: unexpected type (position:END_DOCUMENT null@1:1 in java.io.InputStreamReader@41a99700)

at http://satextbook.co.za
by
hello,

I have solved the 404 error. Now, I am getting parser exception error unexpected type (position: END_DOCUMENT null@1:1 in java input stream reader @ 1ff22904)

What can be the problem? What should i do to solve this problem?

Thank you very much for your interest
by
By the way, I've changed the address.
by
I guess you both have same errors and most probably due to some element in the post- probably a video or something like that. After login, please try if any other tab are working- tab comes with right swipe from left end. By default the app goes to the recent activity tab. You can try and see if any other tab works. If its any particular post, please inform me.
by
Thank you very much for your reply. None of the tabs are working :(
by
I do think we have the same problem. I have read a thread on this same site where it was mentioned that a similar error such as this was a server issue be a the server issue (the cPanel's .PHP version and things like that). Just so I do not confuse anybody, I get the same error on both the original app  by Noah and yours, Arjunsuresh.
by
Oh. Okay. Then I might not be able to help- its 99% Noah app- I just added Mathjax and changed the layout a bit. If I can reproduce the issue I could have tried to fix.
by
Just to confirm- you are using this plugin rt?
https://github.com/arjunsuresh/q2a-xml-rpc
by
edited by
Was not and that was my problem!!!!!! I thought your q2a-xml-rpc plugin and his are the same. Just checked both's sizes and found a 0.1KB difference. You app works with one of my sites now (I say one because it is the only one I had made this correction on). I am interested on a little tip on hard coding please :P

Edit: Found out that while both your edition and the original app works with your xml-rpc plugin on my 'satextbook' but neither works on my 'satechhelp'. I get a similar error. I use the same hoster for both sites and hence I suppose it is not their end. I now suspect other plugins. I also just found out that only admins can login or use the app. Can you please confirm this last part?
by
For registered users you can give xml-rpc permission here:
admin/permissions

I doubt if any plugin can cause an issue- but videos or similar contents in a post might cause.
by
Understood and thanks for the admin/permissions advise. Will try and troubleshoot the issue with the other site and post back.
by
You are welcome. And please try multiple tabs to see if its a problem for any specific page.
by
edited by
Problem solved :) @poyrazs, Login to cPanel > scroll to Software > click on  select PHP version > select the latest (5.6) and set as current > check the "xmlrpc > click 'Save' ... done.
by
trying to hard code. Do I just change:

public final static String CUSTOM_WEBSITE = null;

to:

public final static String CUSTOM_WEBSITE = www.mywebsite.com;
by
Is this thing working finally?
What is "your site" here?
by
It should work for Q2A 1.7.4 but probably not for 1.8. I'm going to remove the app from play store when 1.8 is released and probably replace it with a webapp which will be very easy to maintain.
by
edited by
I could not get it to work even for 1.7,  Upon run it asks me 3 questions,
 "your site"
" User"
"pass"
1- what does  "your site" mean here? we have to put qaoverflow.in (if we are using our credential that we have created on qaoverflow.in?
2- my id is sth @  gmail, but when i enter it, the app adds another @ at the end of it. What is going on?

I have to create a native app for my site that's why webview won't work for me
by
Your site is your QA site with or without http.
User name and password - as on your site.

I'm not sure you can use email login- i.e., usernames with @ may not work.
Also it won't take Google/FB logins.

This is a very old code by Noah and I just used it for sometime. If you want you can modify and use.
https://github.com/arjunsuresh/qaoverflow
...