Welcome to the Question2Answer Q&A. There's also a demo if you just want to try it out.

Question2Answer 1.8.1 released

+17 votes
326 views
asked Dec 1 in Q2A Core by Scott

Hi everyone, I've finally got around to releasing v1.8.1. This fixes a bunch of issues, including Q2A mistakenly being detected as malware. View the full changelog and download here.

This is my first released managed solely by myself, without needing to wait for Gideon to update the website. So do let me know if I've missed anything off the website :)

Thanks to pupi1985, ProThoughts and jairlopez for contributing to this release, and to everyone who reported issues and helped test.

On another note, I set up HTTPS on the Q2A site a while back. Haven't had any problems thus far, but I will be shortly setting up redirects to the HTTPS version so that everyone is always on this version. I'd suggest updating bookmarks if you have them. Please let me know if you encounter any issues with the HTTPS!

Q2A version: 1.8.1
commented Dec 2 by MKDan
Please concentrate on the speed also. Please implement the latest techniques to speed up the Q2A lighting fast.
commented Dec 2 by fara
Thank you all. I upgraded to the new version. It works very well.

5 Answers

+4 votes
answered Dec 2 by ProThoughts
Great! Thanks Scott for this release.

If anyone would like to try demo of q2a v1.8.1 then it is available here

https://demo.question2answer.info/

Let us know if you see any issues.
+1 vote
answered Dec 2 by MONKEY
Https IS running

I will update the site to this version. thank you for being alive and for you for keeping q2a in development
0 votes
answered Dec 2 by chongshengdz
edited Dec 2 by chongshengdz

I set up HTTPS on the Q2A for a long time, nothing wrong.

admin=>general

Preferred site URL, change http to https,then save.

add below code to .htaccess to redirect http to https.

RewriteCond %{SERVER_PORT} !^443$
RewriteRule ^(.*)?$ https://%{SERVER_NAME}/$1 [L,R=301]

0 votes
answered Dec 2 by Ahmed S

Works on php 7.1 without errors
But on PHP 7.2 there are errors

PHP Warning:  count(): Parameter must be an array or an object that implements Countable in /home/public_html/qa-include/qa-base.php(725) : eval()'d code on line 160
PHP Warning:  count(): Parameter must be an array or an object that implements Countable in /home/public_html/qa-include/qa-base.php(725) : eval()'d code on line 712

commented Dec 2 by pupi1985
Try disabling all third party plugins, check again if you are getting that error and report back
commented Dec 2 by Ahmed S
The error is already caused by the addition of "q2a-ultimate-seo"

https://github.com/q2a-projects/Q2A-Ultimate-SEO/tree/master/q2a-ultimate-seo

What's the solution?
commented Dec 3 by Gurjyot Singh
For me also it happens with Q2A Ultimate SEO and also with Q2A Ultimate Widget pluign.
commented Dec 5 by pupi1985
I'd say creating an Issue in the GitHub project of the plugin is the starting point. If the developer doesn't answer in a short period of time, then probably posting a question here providing the necessary info should be plan B
0 votes
answered Dec 4 by odevbul

Hello there I've updated it to the new version. But structural data fails. It was like that when using the old version. I can't get out of it. 

An acceptedAnswer or suggestedAnswer must be provided.  (error)
answerCount is a recommended field. Please specify a value if applicable. (
warning)
...